Проблема с сохранением в SDK.

30 янв. 2016 г., 17:56

Проблема с сохранением в SDK.

В блоге modxSDK

Здравствуйте.
Суть проблемы: делал сайт на локальном сервер (Operserver), по не знанию (впервые знакомился с modx revo) ставил покеты в ручную (ace, console, getpage, modxsdk, modxsite, modxsmarty, phptemplates). По окончании работ настал момент переноса сайта на тестовый сервер в интернете. Осуществлял перенос с помощью Vapor (ставил чистый modx revo 2.4.2) и устанавливал полученный пакет.
Все перенеслось без ошибок, единственная проблема при редактировании файлов через modxSDK данные сохраняются, но на сайте изменения не отображаются и если зайти по фтп и открыть этот же файл, то изменений не наблюдается. Причем если редактирует другой человек из другого города, то я вижу его изменения через SDK.
Была версия что сохраняются файлы по другому пути, но поиск по содержимому в файлах сайта и в базе также ничего не дал.
Ставил также чистый modx revo (2.4.2 и 2.3.6) на этот же сервер и пакет shopmodxbox на этот же сервер. Такой проблемы в этом случае не наблюдалось.
Поиск решений схожих проблем ничего не дал. Подскажите, если есть какие идеи.
Заранее спасибо.
Причем если редактирует другой человек из другого города
Редактирует через что? Так же через modxSDK или как? Или какой-то другой программой редактирует? Скорее всего проблемы просто с правами на файлы. К сожалению, я так и не добрался прописать вывод ошибки в случае невозможности переписать файл, то есть может из-за прав и не может переписать файл, но не говорит об этом.
Редактирует любой файл. Я его потом смотрю и изменения есть, но на сайте их не видно. Также через SDK. Понял, попробую выставить для теста права 777
К сожалению, это не помогло.
777 — это на папки. На файлы 666 надо, если надо убедиться, что права полные даны. А вообще на рабочем сайте права должны быть 775/664.
Если так же через SDK, то совсем не важно из какого города он, все равно идет работа от имени веб-сервера. 98% у вас какой-нибудь adBlock или типа того стоит. Проверьте что у вас из браузера запросы на сервер идут и что ответ корректный возвращается.
Натолкнули на мысль, спасибо. В базе были неверно прописаны пути до папок с шаблонами. Состояли частично из путей на обоих серверах. При переносе видимо некорректно прописались Было так /путь сервера 1/путь сервера 2/core/components/modxsite/controllers/
Ну эта проблема ушла, спасибо.

Добавить комментарий