Пока не ставьте MODX 2.4.0

Fi1osof
21 авг. 2015 г., 19:06

Пока не ставьте MODX 2.4.0

18-го августа вышел MODX Revolution 2.4.0. Вот его пока не советую ставить. На modx.про жаловались многие на кучу багов. Я много багов не нашел (в целом ОК работает), но что нашел, расстраивает очень. В частности куча ошибок с сохранением параметров элементов. То есть в том же шаблоне параметр tpl не получается изменить. Говорит что ОК, а обновляешь — старое значение. Совсем не исключено, что он обновляет что-то совсем не то, так как замечен другой очень пакостный баг — затирка наборов параметров… При сохранении любого TV-параметра (в редактировании параметра), отправляется на сервер идентификатор со значением «По умолчанию». Это очень плохо. Попробуйте, к примеру, вызвать $modx->getObject('modResource', 'По умолчанию или любое другое строчное значение'). Получите первый попавшийся объект документа. Так же и здесь — обновляешь ТВ-ху, а сбрасывает параметры сниппету (из-за чего лично у меня менюха слетала, так как параметры для Wayfinder сбрасывались).
В общем, ждем следующего релиза.
UPD2:Все, в версии 2.4.2 приняли багфикс.
Сейчас просто некогда. Чуть позже если время будет, доберусь, гляну.

Добавить комментарий